
    
Creating new jigsaws

The steps involved in generating a new jigsaw are:

1.    Open a bitmap image file
2.    Decide whether you want to stretch the image
3.    Choose the number of pieces
4.    Choose the oddness factor
5.    Press the Generate button
6.    Press the Save button

Before pressing the Save button you can repeat any of the above steps to change the way the 
jigsaw looks.

See also:
Color depth
Resolution
What makes a good jigsaw?
Distributing new jigsaws



Number of pieces

Enter the desired number of pieces for the jigsaw.    The actual number generated will often be 
slightly different to cater for the number of rows and columns required to fit the jigsaw's shape.    
Changing the size of the window will update the jigsaw, possibly with a different number of rows 
and columns.

You can select between 4 and 4,000 pieces.    The upper limit was set to avoid pieces becoming 
impractically small.    Additionally, pieces will not be made smaller than 8 pixels so to create a 
puzzle of 4,000 pieces you will need a large image, at least 640x480.    You can stretch an 
image as large as your screen will allow, however see what makes a good jigsaw.

See also:
Creating new jigsaws
Distributing new jigsaws



Oddness

Enter a number to determine the shape of the generated pieces.    The higher the number, the 
more irregularity is introduced in the shapes.

0: Pieces perfectly formed with identical connections.
1:    Pieces perfectly formed with random connection symmetry.
2: Slightly irregular with random width and height.
3-9: Increasing irregularity.
10: Maximum irregularity - see warning below.

An oddness factor of 10 can produce strange shapes that can sometimes give rise to physically 
impossible piece outlines.    This can cause holes in the completed jigsaw where it becomes 
impossible for pieces to physically match up with each other.    Be on the lookout for this when 
creating a jigsaw of maximum oddness!

A value between 3 and 7 gives the most pleasing "traditional" jigsaw effect.

See also:
Creating new jigsaws
Distributing new jigsaws



Generate button

Press the Generate button to generate a new set of pieces and display their outlines over the 
loaded image.    Press Generate after you change the number of pieces or the oddness factor.    
You can press Generate as many times as you like to find the most pleasing jigsaw.    Then 
press the Save button.

See also:
Creating new jigsaws
Distributing new jigsaws



Stretch

This checkbox can take one of three values.    When unchecked, the image assumes its original 
size from the bitmap file ("Original").    When checked, the image will either fit the whole window 
("Stretch") or become as large as possible while still maintaining it's original proportions 
("Scale").

With Scale or Stretch selected you can resize the window and the image will be resized 
appropriately.    Uncheck the box and the image will resume it's original size again.

Notes:
In general it is better to use "Scale" than "Stretch" to maintain the correct proportions of an 
image, unless you particularly want to create a special effect.

See also:
Creating new jigsaws
Distributing new jigsaws
Color depth
Resolution



Save button

Once you are happy with the jigsaw you have generated, press the Save button to enter a 
description of the jigsaw and to save it to disk.

See also:
Creating new jigsaws
Enter new jigsaw description
Distributing new jigsaws



Enter new jigsaw description

Please enter a title for the jigsaw, your name and a brief description of it.

The title and your name can be up to 64 characters, the description can be up to 1024 
characters.

See also:
Title
Creator
Description
Creating new jigsaws
Distributing new jigsaws



Title of new jigsaw

Enter a short title for the jigsaw.    The title can be up to 64 characters.

See also:
Creating new jigsaws
Distributing new jigsaws



Creator of new jigsaw

Enter your name.    You can enter up to 64 characters.

See also:
Creating new jigsaws
Distributing new jigsaws



Description of new jigsaw

Enter a brief description of the jigsaw, up to 1024 characters.    You do not need to enter the 
number of pieces or size of the image since this is saved and displayed automatically.

See also:
Creating new jigsaws
Distributing new jigsaws



Jigsaw Preview Screen

The Jigsaw Preview screen lets you open a new jigsaw puzzle or one that you have started 
solving and saved part way through.    You can also open a bitmap (.BMP) image file if you wish 
to create a new jigsaw.

To quickly open a jigsaw, click on the tabs to find one you like and then press the Open button.

The detailed steps to open a jigsaw are as follows:

1.    Choose the file type to open (e.g. "Jigsaws")
2.    Set the disk drive and directory if necessary
3.    Choose a jigsaw by clicking on a tab to preview it
4.    Choose the difficulty level, if desired.
5.    Press the Open button.

Notes:
Jigsaw Preview is accessed from the File/Open menu or via the toolbar.
The CD-ROM version contains subdirectories of various jigsaw themes.    Click once on a 
subdirectory to display all the jigsaws of the chosen theme.

See also:
Most recent file history
Color depth



File type

The file type can be one of:

1.    Jigsaws.    These are unstarted jigsaw puzzles.
2.    Saved Jigsaws.    These are puzzles that you have started and saved.
3.    Bitmap (.BMP) image files.    Opening one of these lets you create a new jigsaw.



Drive and directory

Normally you will not have to change the drive and directory to find the jigsaws supplied with 
this game.    You will only need to change these if you wish to load jigsaws not in the local or 
working directory or if you wish to load bitmap images to create a new jigsaw.



Choose a file

Click on one of the tabs to preview an image from the available jigsaws.    Information about the 
jigsaw is also displayed.    When you have chosen a jigsaw you wish to play, press the Open 
button.



Registration password

Enter your Name and Registration password exactly as supplied to you by Gray Design 
Associates.

See also:
Order form



Piece size

Accessed from the Tools menu or via the toolbar or via the board popup menu.

This feature allows you to adjust the size of the current jigsaw to between 10% and 300% or its 
original size.    If you find you keep running out of room then first try enlarging or maximizing 
your window.    (Drag one of the corners of the window with the left mouse button to change the 
window size).    If the pieces will still not fit then reduce the piece size appropriately.

A sample piece is redrawn as you click on the scroll bar buttons to change its size.    100% 
indicates the original creation size.    When you think the piece is about the right size to fit all the 
pieces on the screen then press OK to apply the change.    There will be a delay while all the 
pieces are regenerated at the new size, redrawn and rotated if necessary.

Notes:
As you solve the jigsaw you will find you have more space available for pieces and you might 
find it advantageous to increase the size.    At the beginning of a very large jigsaw you may want
to initially reduce the size.    Changing the piece size does not affect the positioning or 
orientation of pieces.

There is a lower limit on the size of an individual piece so the scrollbar limits are adjusted 
accordingly and will not always reduce to 10%.    There is no upper limit but see below.

Rotating pieces can be a very slow process in Windows.    Resizing a jigsaw with a large 
number of pieces with rotation enabled can take quite a while.    This is especially true when 
running in other than 256-color mode.    The more pieces a jigsaw has and the larger you make 
the pieces, the longer it will take to regenerate and rotate them.    At very large sizes, causing 
the jigsaw to be bigger than the screen size, you may find you run low on Windows memory at 
which point your system could slow to a crawl.    If this happens wait for the process to complete 
and set the piece size to a more sensible value!



Reset evaluation period

Enter the code exactly as supplied to you by Gray Design Associates.

See also:
Order form



Auto-solve

Choose this cheat option to automatically solve the jigsaw.    You can start or stop the process at
any time and continue manually.    During Auto-Solve most of the other functions are still 
available, such as changing the piece size, rotating pieces, unlocking them, arranging them etc. 
Picking up pieces is disabled.

You can adjust the speed at which the jigsaw is solved by clicking on the scrollbar arrows.    A 
graph is displayed showing the percentage complete.

Notes:
The process may be slower on some machines if sound is enabled.

See also:
Auto-Solve!
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Introduction - features at a glance

What makes this program the best?

1.    Powerful!    Play and create jigsaws from 4 to 4,000 pieces.

2.    Easy!    Even a complete novice can start solving jigsaws immediately.    The jigsaw preview 
screen makes finding your favorite jigsaw a snap and you can even specify how many pieces 
you want.

3.    Full-featured!    Automatically arrange pieces around the outside of the board to leave room 
to solve the puzzle.    Other programs make you scroll the screen to find a piece.    You can 
never lose a piece "off screen" with this program!    Choose to arrange pieces by shape or color, 
as you wish.    Change the size of pieces on the fly.    Now you can fit all of the pieces on the 
board all of the time.    And it's so easy to create new jigsaws!    Of course there's also flying 
hints, context sensitive help, toolbar, status bar, music and sound, as you'd expect.

4.    Fun!    The jigsaws look (and sound) great.    Just like real ones.    Sneaky cheat modes let 
you flash the piece you're looking for, or fetch it, or turn pieces the right way up.    You can even 
watch the jigsaw solve itself.



Getting started

Hint boxes will appear when the cursor is over a toolbar button and helpful descriptions are 
displayed in the lower status panel.    Context sensitive help is available by pressing F1.

Select a jigsaw in the Jigsaw Preview screen where you can preview the available jigsaws.    
Press the Open button to load a jigsaw.    Alternatively use the history file list in the File menu as 
a shortcut to open a recently loaded jigsaw.

When a jigsaw is loaded, two new popup menus are available using the right mouse button.    
Click right on an empty part of the board to get the board popup menu.    Click right on a single 
piece or group of connected pieces to get the piece popup menu.

Use the left mouse button to move pieces around the screen.    You can pick up a group of 
single pieces by dragging a rubber band box around them first.    If you prefer, arrange the 
pieces in a grid pattern or around the edge using the Tools menu.

Hold down the Ctrl or Shift key to change the action of the mouse buttons when clicking on a 
piece.    Hold down Ctrl to rotate a piece left or right.    Hold down Shift and click left to fetch the 
connecting piece and click right to highlight the connecting piece.

Adjust the Piece size, as you wish.

And if you get stuck, you can always resort to cheating!



Saving a jigsaw

You may save a currently loaded jigsaw to preserve the positions of the pieces so that you can 
resume playing later.    You will be automatically prompted to save a game if you attempt to load 
a new file or quit the program.    You can save the game at any time during play.

Press the save button on the toolbar or select Save from the File menu or press Ctrl+S.

If you have never saved the game before you will be prompted for a file name which defaults to 
the same name as the jigsaw but with a different extension.    Unless you wish to change the 
name, simply press the Ok button.    On subsequent saves you will not be prompted for this 
filename again.    If you wish to save to a different file, select Save as... from the File menu.

When you wish to reload your saved game at a later time, either select it directly if it still 
appears in the most recent history file list or use the Jigsaw Preview feature and set the file type
to Saved games to find it.



Program Features

Program features are accessed via the Tools menu, the Cheat menu, the toolbar, the board 
popup menu and the piece popup menu.    There are three types of features; those that affect 
the whole puzzle, those that affect a single piece (or group) and those that involve cheating.

Features affecting the whole puzzle:
Arrange at edge
Arrange in grid
Disarrange
Piece size
Tunes...

Features affecting single pieces:
Rotate right
Rotate left
Unlock piece
Send to back

Features involving Cheating:
Right way up!
Hint!
Solve!
Show neighbor!
Fetch neighbor!

Notes:
The cheat functions can be disabled (to avoid temptation) in the Cheat menu.    Where cheat 
functions appear in the popup menus they are separated from other menu items by a line to 
avoid accidental invocation and are followed by an exclamation point.



Shortcuts

The following shortcuts are available when a jigsaw is loaded:

Ctrl+S Save the game so it can be resumed later.
Ctrl+left button Rotate a piece or group of connected pieces left.
Ctrl+right button Rotate a piece or group of connected pieces right.
Shift+left button Fetch this piece's connecting neighbor.
Shift+right button Flash this piece's connecting neighbor.
F1 Context sensitive help.
Alt+F4 Exit the game.

Notes:
A full list of controls and shortcuts can be viewed while playing by pressing the Quick Help 
button on the toolbar or selecting "Quick Help" in the Help menu.



Cheating

The following cheat functions are supported if Allow Cheating is enabled in the Cheat menu:

Show neighbor!
Fetch neighbor!
Right way up!
Hint!
Auto-Solve!



Options

The Options menu contains the following options:

Picture
Sound
Music
Outlines
Shadows
Sort by Shape
Sort by Color
Timer display
Number display
Rotating Pieces

and the following Advanced options:
Background Color...
Alternative mouse action



Hints on Solving Jigsaws

The traditional technique used to solve a jigsaw is as follows:

1.    Find the four corner pieces and all the edge pieces.    These will have one perfectly straight 
edge, with corner pieces having two.
2.    By studying the picture, try to place the edge pieces in the approximate position to complete
the perimeter of the puzzle.
3.    Sort the rest of the pieces into groups of similar color.
4.    Finally study the picture and try to spot obvious features which can be recognized in 
individual pieces.    The more pieces there are the harder this becomes since less of the overall 
picture can be seen on any one piece.    Small objects and boldly colored lines are the easiest to
spot, large areas with little contrast can be almost impossible.    Then the shape of the piece 
becomes your only clue.

The features of this program can help with the tedious steps:
1.    Sort by Shape
2.    Arrange at Edge
3.    Sort by Color

And if step 4 proves too difficult, there's always the last resort of
4.    Cheating!



Rotation

Pieces can be rotated if "Rotating Pieces" is enabled in the Options menu.    On loading a new 
jigsaw the pieces will be randomly rotated in one of four orientations, i.e. facing up, right, down 
and left.    The correct orientation is, of course, up.

To rotate a piece or group of connected pieces, either click right on a piece to display the piece 
popup menu, or hold down the Ctrl key and use the left and right mouse buttons to rotate the 
piece directly one quarter turn left or right, respectively.

A single piece, a group of connected pieces or all pieces in the jigsaw can be turned the right 
way up automatically by cheating with the Right Way Up! command.

Notes:
Disabling the "Rotating Pieces" option during a game when some pieces are incorrectly rotated 
causes a prompt asking whether you wish to turn all pieces the right way up.    Not doing so 
would make the puzzle impossible to solve so if you answer No, rotation is kept enabled.    
Similarly, loading a puzzle with some rotated pieces causes a similar prompt.

Enabling the "Rotating Pieces" option during a game causes a prompt asking whether you 
would like to rotate some pieces randomly.    The position of pieces is unaffected either way.

See also:
Shortcuts



Arranging and sorting pieces

Several combinations of sorting and arranging pieces are available.    Pieces can be arranged 
via the Tools menu or the board popup menu in either a grid pattern or around the edge of the 
board.

When arranging, pieces can be unsorted, sorted by shape,    sorted by color or sorted by shape 
and color, depending on how the two sorting options are checked in the Options menu.

Use the Disarrange feature, accessed via the Tools menu, to reverse the effect of arranging 
pieces.    All single pieces will be randomly scattered (and rotated if "Rotating Pieces" is enabled
via the Options menu) around the board.

Notes:
Normally only pieces that you have never before moved will be arranged.    A side effect of the 
Disarrange feature is to release all single pieces, whether previously moved by you or not, so 
that they are then free to be arranged again.    If you wish to arrange all singe pieces, including 
those you have previously moved, select Disarrange before one of the Arrange commands.

Sorting and arranging pieces is not considered cheating since it merely removes the drudgery of
a simple but tedious task many people do as a matter of course when starting a jigsaw.



Miscellaneous functions

The following miscellaneous functions are accessed via the piece popup menu.

Unlock
Send to back



Custom Difficulty

Enter a number between 4 and 4,000 to select the number of pieces you would like in the 
jigsaw.    The actual number will often be slightly different to fit the size and shape of the jigsaw.

Notes:
To redisplay this dialog box you will need to click on another Level setting and then click on 
"Custom" again.
Very large numbers may not be achievable if the image is too small since the piece size would 
become impossibly small.    It is possible to create new jigsaws that would allow the maximum 
number, if desired.

See Also:
Creating new jigsaws



    
Color depth

Windows 3.1 supports bitmap files of various color depths.    Namely 2, 16, 256 and 16.7million 
colors.    These are also referred to as 1, 4, 8 and    24-bit color files, respectively.    Windows 95 
also supports 16-bit and 32-bit color depths which give up to 65,536 and 16.7million colors, 
respectively.

Any new jigsaw you create will take on the color depth at which Windows is currently running, 
no matter what the original color depth of the bitmap file.    In other words if you attempt to read 
in a bitmap of a higher color depth than you are currently running Windows, you will lose a lot of 
colors.    Conversely, if you read in a bitmap of a lower color depth than you are running, it will 
not gain any more colors but will be created at a higher color depth which wastes space in the 
jigsaw file you create.

Although this program supports all the above color depths, at the time of writing most people are
only running Windows at a color depth of 8-bits, or 256 colors.    The reason for this is that 
graphics-intense programs run much faster since 1 byte corresponds to 1 pixel on the screen, 
making things very efficient.    For this reason it is suggested that in general you should run 
Windows in 256-color mode when creating new jigsaws.



Resolution

Windows can be run at many different screen resolutions, from 640x480 pixels to 1600x1024 
and above.    Although jigsaws can be created this big it is not advisable for two reasons.    
Firstly, the pieces of an unsolved jigsaw take up far more space on the screen than when it is 
solved.    Although the solver can reduce the size of pieces while playing, it is better not to force 
someone to do this and to choose a more suitable size in the first place, between a half to a 
quarter of the screen size.    Secondly, a huge puzzle takes a lot more disk space, memory and 
cpu power to process.    A puzzle that always has to have its pieces made smaller will waste disk
space and slow down the game, making solving it less enjoyable.



Distributing new jigsaws

The capability is provided for you to create new jigsaws using any Windows BMP file.    By using
this program you agree to the following important considerations:

1.    You must have sufficient rights to distribute any images you use.
2.    Neither the author David P. Gray, or Gray Design Associates, accept any liability for any 
jigsaw images you produce with this program.
3.    Jigsaws created with this product cannot be sold.
4.    Jigsaws created using an evaluation version of this product cannot be distributed.
5.    All Jigsaws and images supplied with the program are copyrighted material and cannot be 
redistributed outside the program.
6.    Purchasers of the full-version have a limited right to create and distribute new jigsaws that 
comply with the above statements and the following:    Jigsaws must be distributed entirely 
separate from the game and our name must not be associated with them.

You must be sure before you distribute any new jigsaws that any images you use are either 
royalty-free or you hold the copyright.



Credit Card

Use our credit card service to pay using Visa, Mastercard, Access, Discover, American Express 
or any credit card bearing these marks.    This is also an excellent way to pay internationally 
since the amount is automatically converted to your local currency.



CompuServe

CompuServe is an international information service provider (effectively a huge global BBS) 
which many people subscribe to.    It is better organized than the Internet currently is and special
interest forums are moderated by sysops.    Among their services to independent software 
authors they include the facility for customers to register or order products from the authors and 
add the charge to their CompuServe bill for that month.    We receive notification of the order the
same day via email.    This is an excellent, and perhaps the easiest, way to pay Internationally.    
Gray Design Associates' CompuServe ID is 73607,2105 or DGray@compuserve.com



World Wide Web

The World Wide Web is an interlinked network of Internet sites which can be navigated using a 
suitable "Web Browser" by clicking on hyperlinks, much like you are doing now in this Windows 
Help file.    Each link represents a page of text and graphics in a hierarchy, the topmost page of 
any particular author or organization is known as their "Home page".    Gray Design Associates' 
Home Page is http://www.dgray.com



Most recent file history

A list of the five most recent files is displayed in the main File Menu.    Select one of the files as a
shortcut to opening a file, rather than using the Open File screen.

Notes:
To help new users, the Jigsaw Preview screen is automatically opened when the program starts 
up, if there are fewer than five files in the history list.    By the time you have opened five 
different files we assume you are familiar enough with the program to decide when you want to 
use the previewer.



Rubber band selection

Select a group of single pieces by clicking the left mouse button on an empty area of the board 
and dragging a rubber band box around the pieces.    Selected pieces are then highlighted and 
can be moved as a single piece.



Board popup menu

This popup menu is activated by clicking the right mouse button on any empty region of the 
playing board when a puzzle is loaded.    It duplicates most of the commonly used items from 
the Tools menu and Cheat menu.

See also:
Program features



Piece popup menu

This popup menu is activated by clicking the right mouse button on a single piece or group of 
connected pieces.    Since the actions are jigsaw piece-specific, these features are not 
duplicated in any other menu or toolbar button.    The piece rotation and fetch/show neighbor 
features are also accessible by shortcuts.

See also:
Shortcuts



Arranging pieces

Accessed from the Tools menu and board popup menu.

Pieces can be arranged at any time either in a grid formation using the whole playing area or 
around the edge of the playing area to leave as much room as possible to solve the puzzle in 
the center.    If sufficient room is unavailable, try increasing your window size or reducing the 
Piece size as necessary.

Both the arrange functions can additionally sort pieces by shape and color, depending on the 
settings in the Options menu.    Sorting by shape puts the corner pieces first, followed by the 
four sets of edge pieces, followed by all other pieces.    Sorting by color attempts to place pieces
of similar shading next to each other.    If both options are selected then shape takes priority 
over color in the sorting algorithm.

Notes:
Only single pieces that have never been touched are arranged.    It is assumed that pieces you 
have moved, and groups of connected pieces, are best left where you put them!    You can 
arrange at any time to fill holes after you move a piece.    Arranging pieces with no sort option 
selected places them in a random but repeatable order.    Changing a sort option does not cause
an automatic rearrangement.

See also:
Disarrange



Disarrange

Accessed from the Tools menu.

Select this to randomly position any single pieces.    If Rotation is enabled in the Options menu 
then single pieces will also be randomly rotated.    Groups of two or more connected pieces will 
not be affected.

Use this feature if you want to reverse the effect of arranging pieces, or to create a greater 
challenge.

See also:
Arrange pieces



Rotate pieces

Accessed from the piece popup menu and via Shortcuts.

Use this feature to rotate a single piece or a group of connected pieces right or left a quarter 
turn at a time.

See also:
Cheating



Unlock piece

Accessed from the piece popup menu.

Use this to unlock a single piece from a group of connected pieces.    This feature is not really 
useful for solving a puzzle but is included for completeness.

Notes:
By unlocking a piece from a completed puzzle and replacing it, you can repeatedly "solve" the 
puzzle to get the congratulations message and sound effect again.



Send to back

Accessed from the piece popup menu.

Use this feature to place a single piece or a group of connected pieces behind all other pieces 
on the board.    This is useful if you believe a group of pieces may be hiding some other pieces.

An alternative to this feature might be to arrange all loose pieces around the edge of the board.

See also:
Arranging pieces



Right way up!

Accessed from the Cheat menu, board popup menu and piece popup menu.

When invoked from the Cheat menu or the board popup menu, this feature affects all pieces.    
The effect is to turn all pieces the right way up.    In other words, the correct orientation as if the 
puzzle were solved.

When invoked from the piece popup menu, only the affected piece or group of connected pieces
is rotated.

Notes:
This feature is considered cheating.
This feature is unavailable if Allow Cheating is disabled in the Cheat menu.



Auto-Solve!

Accessed from the Cheat menu and the board popup menu.

Use this feature to start automatically solving the puzzle.    The largest interlocked group is 
chosen as the root of the puzzle, rotated correctly if necessary and moved to a suitable position 
near the center of the board.    Pieces are then randomly fetched to this group at a speed 
selected by the scrollbar in the Auto-Solve dialog box.

Notes:
This function is considered cheating.
This feature is unavailable if Allow Cheating is disabled in the Cheat menu.

See also:
Auto-Solving



Show neighbor!

Accessed from the piece popup menu and Shortcuts.

Use this feature to highlight the connecting neighbor of a piece.    The cursor must be positioned
on the piece, near one of the four edges.    It is useful if you are unable to locate the piece to 
connect.    Unlike the Fetch neighbor! option it does not automatically orientate the connecting 
piece and fetch it.

Notes:
This feature is considered cheating.
This feature is unavailable if Allow Cheating is disabled in the Cheat menu.

See also:
Fetch Neighbor!



Fetch neighbor!

Accessed from the piece popup menu and Shortcuts.

Use this feature to fetch the connecting neighbor of a piece.    The cursor must be positioned on 
the piece, near one of the four edges.    It is useful if you are unable to locate the piece to 
connect.    A side effect of this is to automatically rotate the fetched piece to the same orientation
of the original piece.    Also if the fetched neighbor is part of a group of connected pieces, the 
whole group is fetched.

Notes:
This feature is considered cheating.
This feature is unavailable if Allow Cheating is disabled in the Cheat menu.

See also:
Show Neighbor!



Picture

Use this option to display an image of the completed puzzle in a window overlaying the board.    
The picture may be moved and resized as desired.    The picture display can be toggled from 
both the Options menu and the toolbar.

Notes:
The image can be zoomed to full size with the rest of the screen blanked by selecting "Zoom 
picture" in the View menu.



Sound

Your computer must have a sound card and speakers attached to hear any sound effects during
the game.    Sound effects include the sound of a piece interlocking and an appropriate 
response when you complete a puzzle.    Sound can be toggled from both the Options menu and
the toolbar.

Notes:
The interlocking sound is played whenever you enable sound to confirm it is working and so you
can adjust your volume level, if necessary.
You can repeat the sound when you solve your puzzle by unlocking a piece and placing it again.
On some machines the Auto-solve feature may be slower when sound is enabled.



Outlines

Accessed from the Options menu.

Use this feature to display a pleasing 3D outline with a piece.    As the puzzle is solved it helps 
give the effect of a real puzzle.    With outlines disabled you will not be able to discern individual 
pieces within an interlocked group.

See also:
Shadows



Shadows

Accessed from the Options menu.

Use this feature to display a pleasing black shadow when a piece or group of pieces is moving.   
It gives the effect of lifting the piece from the board while it is being moved.

Notes:
When dealing with very large jigsaws on a slow computer you can disable this feature to make 
movement of pieces faster.

See also:
Outlines



Timer display

Accessed from the Options menu.

Use this feature to display an updating timer in the status panel at the bottom of the window.    
The time is updated in hours and minutes and starts when you first load a jigsaw.

Notes:
The time is stored when you save a puzzle and resumed when you reload it.
The timer is stopped when you solve a puzzle.
The timer's internal resolution is seconds even though only hours and minutes are displayed.

See also:
Number display



Number display

Accessed from the Options menu.

Use this feature to display an updating count of the number of pieces solved out of the total 
number of pieces in the jigsaw.    The numbers are displayed in the status panel at the bottom of
the window.

Notes:
The number of pieces solved is defined as the number of pieces which are joined to another 
piece.

See also:
Timer display



What makes a good jigsaw?

The basic rule is to have as much interesting detail over as much of the jigsaw as possible.

Large areas of similar color, such as a cloudless sky or a calm sea, make for very difficult 
puzzles.    Similarly, an area of very similar patterns such as a field of corn or    a long shot of a 
crowd can be just as hard.    In these areas the puzzle can only be solved using the shape of a 
piece as a guideline.

The easiest puzzles are those with many small areas of distinct features that can be recognized 
on individual pieces.    These could be anything, but good examples are people, animals, 
buildings, cars, even writing.    Any distinct lines formed by roads, or natural features help to 
make the puzzle easier.    Areas of bright color help so long as the colors are distinct and not too
large.    For example a flower arrangement in a vase would be easy but a sea of poppies would 
not.

The number of pieces determines the final difficulty.    As a rule of thumb:

Easy : 4 - 50 pieces
Medium: 50 - 200 pieces
Hard: 200 - 400 pieces
Expert: 400 - 4,000 pieces



Order Form

Select "Ordering Information" from the Help menu in the program to popup the order form if it is 
not already on display.



Hint!

Accessed from the Cheat menu and the board popup menu.

Use this feature to suggest the next two pieces to connect.    A piece is chosen at random from 
the largest completed section of the jigsaw and flashed alternately with its unconnected 
neighbor.

Notes:
It is up to you to determine how the two suggested pieces connect.    If rotation is currently 
enabled the pieces can have different orientation.

This feature is considered cheating.
This feature is unavailable if Allow Cheating is disabled in the Cheat menu.



Music

Accessed from the toolbar and Options menu.

Use this to toggle background music on and off while playing.

Your computer must have a sound card and speakers attached to hear the background music.

See also:
Specifying tunes



Bonus Games

The CD-ROM Gold Edition comes with two bonus games for Windows, by the same author.    
Both are fully playable, non-limited, first-episodes of their own trilogies.    They are suitable for 
the whole family and are sure to provide countless hours of fun.

The first, Hugo's Horrific Adventure, is a point & click graphical adventure game in which you 
play the part of the hero Hugo in his mission to rescue his sweetheart Penelope from a haunted 
house, exploring and picking up items to solve the many fiendish puzzles along the way.

The second game, Nitemare-3D, continues the same theme but in a more action-oriented style,
using high-speed real-time 3D first-person perspective graphics.    Although loaded with fiendish 
logic-puzzles, more emphasis is given to fending off nasty ghosts, mummies, monsters and 
assorted villains who are out to stop you.

The bonus games require Windows 3.1 or higher and can be installed separately from Jigsaws 
Galore.    Details of how to order the remaining games in the trilogies are also included.

Please note that the bonus games are only available when ordering the CD-ROM Gold Edition.



    
Frequently Asked Questions

Q.    I've just run the program.    What do I do first?
A.    You'll be looking at the Jigsaw Preview screen.    Press the "Open" button to open the first 
jigsaw.    You will see the jigsaw pieces randomly placed on the board.    You can start moving 
pieces by dragging them around using the left mouse button.    See the other mouse controls by 
pressing the Quick Help toolbar button (the question mark).    Then browse the Contents page to
see all the powerful features available!

Q.    I saved a jigsaw and now I can't find it.    What can I do?
A.    The smart way is to close the Preview screen and use the Most Recent File List.    Saved 
games have an extension of ".jss" and your saved game will show up somewhere in the list so 
long as it was one of the five most recently opened files.    As you go down the list with the 
mouse you will also see the full path shown in the bottom status line.

The program defaults to saving in the same directory as the original jigsaw.    Don't forget to click
on the "Saved Jigsaws" button to view them if you use the Preview screen.    If you are playing 
the CD-ROM version and chose to access the jigsaws on the CD-ROM then saved games are 
stored by default in the program drive and directory since CD-ROMs are, of course, read-only.    
Either use the recent history list as above or change the drive and directory in the Preview 
screen to find your saved game.

Q.    What's the right mouse button for?
A.    The right mouse button pops up two handy menus.    If your mouse cursor is over a piece 
then you will see the piece popup menu.    If the cursor is over an empty space on the board, 
you will see the board popup menu.    See also Shortcuts for some other uses of the mouse 
buttons.

Q.    Can I change the action of the right mouse button?
A.    Yes!    By default the right mouse button pops up two menus but you can change it to rotate 
pieces right.    See Alternative Mouse Action.

Q.    I'm having trouble picking up large groups of pieces.    Why?
A.    You probably have a slow computer and/or graphics card.    When you try to pick up a piece 
or group of pieces, make sure you keep the left mouse button pressed long enough to pick up 
the piece.    Releasing it before you see the pieces picked up will get you nowhere.    You might 
also try reducing the piece size.

Q.    Why doesn't the game let me scroll the window?
A.    Scrolling is a very bad idea since you will find you are spending all your time trying to find a 
missing piece outside the visible area of the window, a most tedious and frustrating way to play.
    
This game lets you change the piece size to suit the area available and can arrange pieces 
around the edge to give you a work space in the middle.    You can also "park" completed 
portions of the puzzle offscreen, leaving just a few pieces visible, to give you more room.    It is 
not possible to lose pieces offscreen.

Q.    Some pieces are the same color as the background, what can I do?
A.    Change the game background color.



Q.    When should I change the difficulty level?
A.    When you first open a jigsaw the number of pieces defaults to that chosen by the creator of 
the jigsaw.    If you like the picture but want to make it easier or harder, you can choose the level 
of difficulty before you open a jigsaw in the Jigsaw Preview screen.    Note that you can only do 
this before you start playing a jigsaw.

Q.    When I select "Custom" why don't I get the exact number of pieces I ask for?
A.    Because some numbers of pieces are impossible to achieve with a traditional rectangular 
jigsaw with rows and columns.    Additionally, a limit is set on how small a piece can be.    As the 
number of pieces increases, the piece size decreases, which limits the maximum number of 
pieces for a given image size.    If you really want a 4,000 piece jigsaw you can create one by 
stretching a BMP file you provide, see Creating a jigsaw.

Q.    When should I change the piece size?
A.    You can change the piece size while playing.    If the playing board looks too crowded, i.e. 
there is no spare room on the board to put solved pieces of the puzzle after maximizing the 
window, then you can reduce the piece size to create more room.    If the pieces are too small to 
see then you can increase the piece size.    See also Changing the piece size.

Q.    How do I arrange the pieces?
A.    Use the Arrange feature to tidy up any loose pieces on the board that you have not moved 
yet.

Q.    When I use "arrange", some pieces don't move.    Why?
A.    The Arrange feature only arranges pieces that you have not touched yet.    It is assumed 
that if you have moved a piece somewhere, you would prefer to keep it there.    If you want to 
arrange all the pieces then select Disarrange first to "un-touch" them.

Q.    When are the Sort options used?
A.    These are used when you Arrange pieces.    You can have neither, one, or both options 
checked.    Use Disarrange to scramble the pieces again.

Q.    What does "Evaluation version" mean?
A.    An evaluation version has been produced to let people try out all the features of the game 
for a limited period and decide whether they wish to purchase it.    After the period has expired 
some of the features of the game are switched off.    The period has been set to 30 "usage" 
days.    This means any number of uses on any 30 different days so if you try the program once 
and then go on vacation for 6 months<!?>, you still have 29 days left to try it out.    Users of the 
evaluation version are not allowed to distribute jigsaws created with it.

Q.    Can I distribute jigsaws I create?
A.    If you use the evaluation version you must not.    If you have paid for the full-version you 
may, so long as you have sufficient rights to the images you use.    On no account must you 
associate any new jigsaws with our name or attempt to attach them to the game distribution file. 
On no account must you use copyrighted material without permission, such as other people's 
photographs or clipart that is not totally royalty-free.    Copyright infringement is covered in most 
of the industrialized countries of the world and considered a very serious offence.    In any event 
you may not sell jigsaws you create.    See also How to order and Distributing new jigsaws.

Q.    Can I distribute the jigsaws supplied with the game?
A.    No.    This would constitute a copyright infringement against both our game and the original 



owners of the included images.    The images are for your personal use within the game only.



Selecting Difficulty Level

The Jigsaw Preview screen lets you choose the difficulty level when you first open a jigsaw.    
Select "Default", "Easy", "Medium", "Hard" or "Custom" to determine how many pieces the 
jigsaw will have.

The "Default" value is the one judged to be the most appropriate.    The jigsaw is supplied with 
this number of pieces and will open significantly faster if the default value is used.    On any 
other setting the pieces have to be built first.

The "Easy, Medium and Hard" settings correspond to approximately 35, 100 and 250 pieces 
respectively.    Choose one of these as a rough guide to how difficult the jigsaw will be.

The "Custom" setting lets you specify more precisely how many pieces you would like.    On 
selecting this option the Custom Difficulty prompt will appear, prompting you to enter the desired
number of pieces from 4 to 4,000.    The actual number generated will usually be slightly 
different to account for the dimensions of the jigsaw.    Also, the maximum number of pieces 
depends on how big the original image is.    The supplied jigsaws are big enough to support two 
or three thousand pieces - if you want the maximum number it is possible to create your own 
very large jigsaws yourself, see creating new jigsaws.

Notes:
Jigsaws are originally supplied pre-built with the default number of pieces.    Choosing any 
difficulty level other than "Default" requires that the pieces be regenerated when you first open 
the jigsaw, a potentially slow process if there are a large number of pieces.    Regeneration is not
required when you reopen a saved game, however.



Music

Background music (MIDI files) may be played during the game.    You must have a sound card 
installed to take advantage of this feature.

Several tunes are supplied and these, along with any other MIDI files you might have on your 
system, can be included in a Play List.    Select "Tools/Tunes..." from the main menu to choose 
which tunes should be included in the Play List.    The supplied tunes will be visible in the 
Source list and are pre-selected into the Play List.    To add any other MIDI files, first find them 
using the drive and directory selection boxes and then add them to the Play List using the copy 
buttons (note the help in the status line when your cursor is above each button).    Alternatively 
you can copy your MIDI files into the jigsaw directory before you start the game.

You can turn background music on and off as you wish during the game, either using the toolbar
button or the "Options/Music" main menu item.    You can skip a tune by turning music off and 
then on again.    When the Play List reaches the end it will start over again.

Notes:
The list of tunes in the Play List is saved in the file TUNES.INI and restored each time you start 
the game.
If no sound card is detected then the Music and Tunes... options are disabled.



Alternative mouse action

The action of the right mouse button can be changed using the Options/Advanced menu.    The 
right mouse button options are as follows:

Default:
Click Right over a piece to invoke the piece popup menu or over empty space to invoke the 
board popup menu.    Press Ctrl+Right over a piece to rotate the piece right.

Alternative:
Click Right over a piece to rotate it right.
Press Ctrl+Right over a piece invoke the piece popup menu or over empty space to invoke the 
board popup menu.

Notes:
The alternative option is intended to provide the easiest way to rotate pieces, i.e. by simply 
clicking right on them.    The disadvantage is that the Ctrl key must still be pressed to rotate left, 
which may prove slightly confusing.    You should consider the alternative mouse arrangement if 
you generally play with rotations enabled.



Changing the background color

The background color of the window can be changed using the Options/Advanced menu.

Use this if your default Windows color scheme closely matches the predominant color in a 
particular jigsaw.    For example, if you were solving a jigsaw with a large amount of blue sky you
might have trouble seeing the pieces if your window background color was sky blue.

You can select one of the predefined colors or create up to 16 custom colors by pressing the 
"Define Custom Colors..." button.



How to Order

We can accept orders via the following methods:
Order by Mail (see below)
Order by Phone
Order via the Internet
Bill your CompuServe account

Standard Edition $29: Includes full-version plus 10 new jigsaws
De-Luxe Edition $33: Includes full-version plus 20 new jigsaws
CD-ROM Gold Edition $43: Includes full-version plus 130 jigsaws and two bonus games!

How to order by mail:
Please enter your name and address, select the product you wish to order and mail the order 
form with the required amount in U.S.$ to Gray Design Associates, PO Box 333, Northboro, MA 
01532.    The check must be drawn on a U.S. bank, we regret we are unable to accept Canadian
and other non U.S. checks but we can accept Canadian Postal Orders in U.S.$ and 
International Money orders in U.S.$.

Countries outside North America:
We welcome orders from around the world.    The easiest way is to use a credit card via fax, 
email or the Internet.    If you do not have a credit card, a check (cheque) in U.S.$ drawn on a 
U.S. bank can usually be obtained in most countries from your bank.    International Money 
Orders (or American Express Money Orders) in U.S.$ can usually be obtained from your local 
post office or bank.

About the Full-versions:
The Standard and De-Luxe Editions include a selection of new jigsaws similar in style to those 
in the evaluation version.    The CD-ROM Gold Edition contains all 130 jigsaws in 11 different 
categories as follows:    Around the world, Animals, Scenic, Food, Festive, People, Transport, 
Nature, Fun, Buildings and Miscellaneous.    The jigsaws are generally larger than those in the 
other editions and are a mixture of spectacular photographic images for the serious jigsaw 
player and fun, colorful jigsaws for younger players or those looking for some light relief.    The 
cute animals, mechanized transport and cartoon-like jigsaws in particular are sure to amuse any
child.    The CD-ROM Gold Edition also includes two action/adventure bonus games.

About the evaluation version
This evaluation version is provided to enable you to fully try out the program with every feature 
enabled.    To protect our time and investment we have limited the evaluation period to 30 
"usage" days.    These can be any 30 different days, not necessarily consecutive, and the 
program can be run any number of times during the period.

During the evaluation period all features are enabled so you can fully evaluate them without 
having to guess what a feature might be like.    We feel this is the fairest way to let you evaluate 
the product without giving it away for free.

After 10 usage days a reminder screen will appear when the program starts up, indicating how 
many days have elapsed.    After 20 usage days the title bar will start to flash the number of days
that have elapsed.    After 30 usage days, the end of the evaluation period, the following non-



essential features will be disabled:

1.    Creating new jigsaws.
2.    Rotating pieces.
3.    Changing the size of pieces.
4.    Cheat functions.
5.    Sorting by shape and color.
6.    Arrange at edge.
7.    Auto-Solve.
8.    Difficulty level.

If you wish to continue using the program you must order a full-version.



Credit Card orders

Use Visa, MasterCard, Amex or Discover via our credit card order taking services:-

These numbers are for CREDIT CARD ORDERS only and not technical help or support.    All 
non-ordering enquiries must be directed to the author at dgray@compuserve.com.

Public (software) Library
Open 7am - 6pm CST Monday - Thursday and 7am - 12:30pm Friday

Phone : 1-800-2424-PsL
Phone : 713-524-6394
Fax : 713-524-6398
Email : 71355.470@compuserve.com

Please quote product #14665 and Std/Deluxe/CD-Gold preference

NorthStar Solutions
Open 10 am - 8 pm EST, Monday thru Saturday

Phone : 1-800-699-6395    (within U.S.)
Phone : 1-803-699-6395    (international)
Fax: 1-803-699-5465
Email: 71561.2751@compuserve.com

Please quote product:
#857 Standard Edition
#858 Deluxe Edition
#859 CD-Gold Edition

If faxing your order, please remember to specify which Edition you want as well as your 
address, credit card number, expiry date and full name as it appears on the card.



Internet (WWW) orders

Visit our Home page to order via the World Wide Web at the following URL:

http://www.dgray.com



CompuServe orders

CompuServe provides an online ordering service (GO SWREG) which allows you to order our 
products online.    The charge is simply added to your CIS bill for the month.

This service provides a really easy way for our overseas customers to order.    We will 
automatically receive the order the same day via email.

After typing GO SWREG, enter either the name=Jigsaws Galore or the product ID=11512 to 
place your order.    You might like to browse our other products under user id 73607,2105.




